Jump to content
UBot Underground

Feature removed or broken in update?

Recommended Posts

I have been a Ubot user for years, and came back to it recently. I now find I can't create a list from list of text in a TextArea box.

I'm using this code (where the list is called "URLs"):

add list to list(%URLs,$list from object(#TextArea0),"Don\'t Delete","Global")

And the error message is saying this isn't supported in my version of Ubot (standard) - but I'm sure I've done this loads of time in the past with earlier versions. Currently using 6.7.6.

If this doesn't work, how can I create a list from text that's entered into a TextArea box?

Link to post
Share on other sites

Thx - tried that - use newline as delimiter and still doesn't work. Set setting to Global - nothing. Reboot and try again (because Ubot is sensitive to errors) - nothing. Set variable to TextArea and nothing. So frustrating when Ubot fails to work like it used to. Nothing I do can pull in data from the TextArea.

Link to post
Share on other sites

Well tried all that - nothing worked, so I decided to uninstall Ubot, download a fresh package and start again.
All good except the licence server is down so I can't start the program. And I can't send a support request email. Jeez, this is so frustrating - what a shambles.
(I've no idea why anyone would trust Seth and his pals to programmatically trade their crypto - I wouldn't let them anywhere near it!)

Link to post
Share on other sites

OK here's the latest weirdness after reinstalling Ubot 6.7.7
I decided to write a short script to demonstrate the issue:

clear list(%test)
add list to list(%test,$list from text(#TextArea0,$new line),"Don\'t Delete","Global")
alert($list item(%test,0))


Note that the TextArea box looks a bit weird - it should fill the header area, not be partially obscured by the browser bar. But anyway...

After running:


After running in Code View mode, the alert gives the correct answer, but the content of the TextArea box gets partially deleted.
But when I run the script in Node View mode, nothing unusual happens - the TextArea box remains untouched.

That said, I can't edit the script: when I enter text it appears in the Search Toolbox window, which makes me think the whole installation is hosed, despite it being freshly downloaded.

Any thoughts?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...