Jump to content



Photo

How Do You Easily Work With Javascript Elements?

redbubble javascript ubot ajax

  • Please log in to reply
14 replies to this topic

#1 candres79

candres79

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationTampa
  • OS:Windows 8
  • Total Memory:More Than 9Gb
  • Framework:v3.5 & v4.0
  • License:Developer Edition

Posted 14 December 2015 - 12:30 PM

So I'm trying to automate this site... http://redbubble.com.

Everything is fine until after I upload my image.

 

On redbubble you can upload one image and they put it on like 20 products. The issue is when it adds the image to all the products you can't easily click on them.

I've tried everything, changing user agents, etc... nothing is working! 

 

I've created a demo account for you to use to see what I'm talking about.

 

Login here: https://www.redbubble.com/auth/login

 

Username: ubotdemo

Password: ubotdemo123

 

Then go here: http://www.redbubble...t-nav-dropdown 

 

...and upload any .png image.

 

Once the image uploads you can see all the products displayed as thumbnails:

 

 

https://drive.google...iew?usp=sharing

 

I can't figure out hot to click on the "Edit" button under each thumbnail. When you click that button, all of that products options open up...

 

(Tee shirt options opened up after button click)

https://drive.google...iew?usp=sharing

 

 

I need to be able to click on the edit button to get these options to open up.

But, then I need to be able to change the color and move that slider to another percentage.

 

I for the life of me can't figure this one out. Maybe you guys can help.

 

Let me know if you need more info or I can clarify in any way.

 

Thanks,

Chris

 

 

 



#2 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3517 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 14 December 2015 - 06:37 PM

i use ubot v5.9.8 and chrome v39 it working

 

see image

Attached Files


New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#3 candres79

candres79

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationTampa
  • OS:Windows 8
  • Total Memory:More Than 9Gb
  • Framework:v3.5 & v4.0
  • License:Developer Edition

Posted 14 December 2015 - 07:59 PM

i use ubot v5.9.8 and chrome v39 it working

 

see image

 

Weird, I'm using the same thing Ubot 5.9.8 & Chrome v39 and I can't click or interact with anything once I upload an image to the site.

 

Have any idea what would be causing this?



#4 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3517 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 14 December 2015 - 08:05 PM

code

navigate("http://www.redbubble.com/portfolio/images/new?ref=account-nav-dropdown%C2%A0","Wait")
change file field(<id="select-image-single">,"C:\\Users\\Apichai\\Pictures\\2015-09-02_16-05-34.png")
click($element offset(<class="rb-button edit-product">,0),"Left Click","No")

New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#5 candres79

candres79

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationTampa
  • OS:Windows 8
  • Total Memory:More Than 9Gb
  • Framework:v3.5 & v4.0
  • License:Developer Edition

Posted 14 December 2015 - 09:02 PM

 

code

navigate("http://www.redbubble.com/portfolio/images/new?ref=account-nav-dropdown%C2%A0","Wait")
change file field(<id="select-image-single">,"C:\\Users\\Apichai\\Pictures\\2015-09-02_16-05-34.png")
click($element offset(<class="rb-button edit-product">,0),"Left Click","No")

 

 

 

click($element offset(<class="rb-button edit-product">,0),"Left Click","No")

 

That's the part that isnt working for me.

 

Anything I try to click on or right click on after I upload the image wont work.

I need to be able to click the edit button, change shirt color, and move the slider to a certain percentage.

 

I can't click on or manipulate any of those.

 

Does clicking on any of those work for you?


Edited by candres79, 14 December 2015 - 09:03 PM.


#6 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3517 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 14 December 2015 - 09:22 PM

see image

Attached Files


New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#7 duncan

duncan

    Member

  • Fellow UBotter
  • PipPip
  • 15 posts
  • OS:Windows 8
  • Total Memory:< 1Gb
  • Framework:v4.5+, unsure
  • License:Professional Edition

Posted 14 December 2015 - 11:00 PM

@prash, I am working on this with Candres.  Can you make a screen capture video demonstrating?  Currently we can't get it to work as you are on your end.  thx.



#8 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3517 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 15 December 2015 - 02:09 AM

@prash, I am working on this with Candres.  Can you make a screen capture video demonstrating?  Currently we can't get it to work as you are on your end.  thx.

I know why.
Sometimes it works But sometimes it does not work
I think the problem is caused by Ubot not load pages.
Please report this problem to Ubot support.


New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#9 candres79

candres79

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationTampa
  • OS:Windows 8
  • Total Memory:More Than 9Gb
  • Framework:v3.5 & v4.0
  • License:Developer Edition

Posted 15 December 2015 - 08:55 AM

I know why.
Sometimes it works But sometimes it does not work
I think the problem is caused by Ubot not load pages.
Please report this problem to Ubot support.

 

 

Did it stop working for you too?

 

I just put in a support ticket, I'm waiting for them to get back with me.



#10 LoWrIdErTJ - BotGuru

LoWrIdErTJ - BotGuru

    Botguru.net

  • Moderators
  • 4850 posts
  • LocationMichigan
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 16 December 2015 - 11:49 AM

Still having trouble?



#11 candres79

candres79

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationTampa
  • OS:Windows 8
  • Total Memory:More Than 9Gb
  • Framework:v3.5 & v4.0
  • License:Developer Edition

Posted 17 December 2015 - 10:23 AM

Yea TJ, still can't seem to get this to work. 

 

Any suggestions?



#12 Varo

Varo

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 95 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 17 December 2015 - 06:26 PM

Same here,

first time was good everything worked

but when i run for second time, it didnt work.

 

This problem is the same problem that i am facing on the other site. (with javascript element)

 

I am thinking to try with Exbrowser plugin, but right now i dont have it



#13 LoWrIdErTJ - BotGuru

LoWrIdErTJ - BotGuru

    Botguru.net

  • Moderators
  • 4850 posts
  • LocationMichigan
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 18 December 2015 - 12:34 PM

change file field(<id="select-image-single">,"PATH TO IMAGE HERE")
comment("offset 0-16 as there are 17 options of edit
0 - Clothing
1 - Mens Graphic T-shirts
2 - Stickers
3 - Phone cases and skins
4 - Prints, cards and posters
5 - Pillows and totes
6 - Pouches laptop skins and sleeves
7 - Duvets
8 - Mugs
9 - Travel Mugs
10 - Leggings
11 - Pencil Skirts
12 - Scarves
13 - Tablet cases and skins
14 - Drawstring Bags
15 - Spiral notebooks
16 - Hardcover Journals")
click($element offset(<class="rb-button edit-product">,0),"Left Click","No")
comment("Front")
click($element offset(<class="label-wrap">,0),"Left Click","No")
comment("Back")
click($element offset(<class="label-wrap">,1),"Left Click","No")
comment("Colors")
clear list(%colors)
add list to list(%colors,$list from text($scrape attribute(<class=w"work-config-color-option body_color_*">,"data-color"),$new line),"Delete","Global")
set(#color,"silver","Global")
click(<style="background-color: #e0e1dd;">,"Left Click","No")
comment("Apply changes")
click($element offset(<class="rb-button red apply-changes">,0),"Left Click","No")



#14 candres79

candres79

    Member

  • Members
  • PipPip
  • 16 posts
  • LocationTampa
  • OS:Windows 8
  • Total Memory:More Than 9Gb
  • Framework:v3.5 & v4.0
  • License:Developer Edition

Posted 19 December 2015 - 09:52 AM

Nope Still not working for me. I tried running this compiled out into a bot too... no luck!
 
Nothing happens when you run it. I made a quick video to show you what's goin on...

 


Edited by candres79, 19 December 2015 - 09:55 AM.


#15 LoWrIdErTJ - BotGuru

LoWrIdErTJ - BotGuru

    Botguru.net

  • Moderators
  • 4850 posts
  • LocationMichigan
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 19 December 2015 - 01:03 PM

I didnt use new browser.

 

the code is not meant to be ran, but stepped through.  so you must put in some proper waits, (wait for) etc.







Also tagged with one or more of these keywords: redbubble, javascript, ubot, ajax

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users