Jump to content
UBot Underground

[FREE PLUGIN] Advanced Shell


Recommended Posts

Advanced Shell/Command Prompt plugin will add 5 new commands/functions to your UBot environment and it will allow you to run Shell command hidden (hode those annoying window popups), write batch commands right inside the UBot (instead of executing batch file) and even retrieve the output that Command Prompt produces (functions).

 

For more information please visit the plugin page:

http://ubotdev.com/free-plugin-advanced-shell

Direct Download

 

http://ubotdev.com/wp-content/uploads/2013/05/Command-Line-Window-300x176.png

 

P.S.: I forgot to remove "delete permanently" command (deletes all files instead of trashing them) from final build, so I'll just leave it as a part of this plugin.

 

UPDATE v1.01: 

Added "Wait For Exit" option which allows you to wait for the command to get executed, or just proceed with next UBot command if you don't want to wait for exit.

  • Like 7
Link to post
Share on other sites

It's not something new to UBot, it will just make it more end user friendly.

 

Nice to hear you are making a good use of it. :)

Link to post
Share on other sites
  • 1 month later...
  • 7 months later...

Has this just all of a sudden stopped working for anyone else?  The ubot native shell still works, but this plugin doesn't seem to anymore all of a sudden.  Delete file permanently still works, but I was using shell batch hidden with no problems, and now it's not working at all.  I can get by with shell, but with shell batch hidden, I wasn't getting the cmd popup, which was much nicer for selling the bot.  Can anyone help me out as to why this might have happened?

Link to post
Share on other sites

It works OK for me, so I guess the problem is on your side. Here is the code that I used:

set(#DIR, $plugin function("Advanced Shell.dll", "$shell batch hidden", "dir"), "Global")

...and it returns the output of dir command.

Link to post
Share on other sites

It works OK for me, so I guess the problem is on your side. Here is the code that I used:

set(#DIR, $plugin function("Advanced Shell.dll", "$shell batch hidden", "dir"), "Global")

...and it returns the output of dir command.

 

Yeah that works fine for me too.  It's the shell batch hidden command that doesn't seem to be running the CMD.

Link to post
Share on other sites

Yeah that works fine for me too.  It's the shell batch hidden command that doesn't seem to be running the CMD.

Shell batch hidden also works for me:

plugin command("Advanced Shell.dll", "shell batch hidden", "calc.exe")

..so I think the problem is on your side. Try using "shell hidden" with your command.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...