Jump to content



Photo

Issue: Ubot Won't Play Youtube Video - How To Click On Youtube Video Play Button?


  • Please log in to reply
10 replies to this topic

#1 memeuu

memeuu

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 88 posts
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 05 April 2020 - 08:24 PM

hello,

 

I am having problem getting ubot to click on youtube play button at youtube.com video page (i.e. )

*Seems like ubot CAN click the play video button from this forum page.

 

BUT ubot cannot click on the play button at the youtube video page?
 

 

 

https://www.youtube....h?v=gORrpDXDML8

 

Thank you for your help and suggestions!


I love ubot when it works right  :D 


#2 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3481 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 05 April 2020 - 09:35 PM

i test on ubot 5.9.44

click(<class="ytp-play-button ytp-button">,"Left Click","No")

New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#3 memeuu

memeuu

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 88 posts
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 06 April 2020 - 05:13 AM

 

i test on ubot 5.9.44

click(<class="ytp-play-button ytp-button">,"Left Click","No")

Thanks for helping. The real issue is that ubot can't click play button at the actual youtube video page 
 

 

 

https://www.youtube....h?v=gORrpDXDML8

 


I love ubot when it works right  :D 


#4 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3481 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 06 April 2020 - 05:50 AM

Play button in the middle of the video?
You may have to use image clicking.

New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#5 memeuu

memeuu

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 88 posts
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 06 April 2020 - 07:40 AM

 

Play button in the middle of the video?
You may have to use image clicking.

 

I tried ubot image click, still not working. Tried different useragent browsers, even using mouse hover over and click, still not working.

Only when I actually click on video through ubot browser manually myself, does the video play. 

Thank you
 


I love ubot when it works right  :D 


#6 pash

pash

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 3481 posts
  • OS:Windows 10
  • Total Memory:More Than 9Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 06 April 2020 - 09:23 PM

I tried ubot image click, still not working. Tried different useragent browsers, even using mouse hover over and click, still not working.

Only when I actually click on video through ubot browser manually myself, does the video play. 

Thank you
 

you use ubot version?


New Plugin:: Advanced Facebook | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint
- Advanced Data Text File | Advanced DateTime | Advanced Dialog | Advanced Document | Advanced Google Blogger V3 | Advanced Google Drive | Advanced Google YouTube V3 | Advanced Image | Advanced Video | Advanced Screen and Windows | Advanced Systems | Advanced Ubot 1 | Advanced Ubot 2 | Advanced WordPress | Advanced Connection | Advanced Twitter | Advanced Email | Advanced PowerPoint

- Advanced Captcha (V3) | Advanced Captcha (V2) (Old) | Create Table From Excel (Lite) | Check Conection | Ubot Enter License | Auto Free Memory
- Working hours GMT+7. i regret sometimes the answer is delayed due to health problems.


#7 memeuu

memeuu

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 88 posts
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 07 April 2020 - 04:48 AM

you use ubot version?

 

I am using newest version Ubot X 6.18
Developer version. Thanks


I love ubot when it works right  :D 


#8 LoWrIdErTJ - BotGuru

LoWrIdErTJ - BotGuru

    Botguru.net

  • Moderators
  • 4843 posts
  • LocationMichigan
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 07 April 2020 - 05:39 AM

believe you can also send the space key to it to start a video playing, 

 

or if problems you might also try at the top click on tools, then options

change the browser listed there to a different version

 

exit there, save source, and reopen 

then nav to an try to click



#9 memeuu

memeuu

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 88 posts
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 07 April 2020 - 09:38 AM

believe you can also send the space key to it to start a video playing, 

 

or if problems you might also try at the top click on tools, then options

change the browser listed there to a different version

 

exit there, save source, and reopen 

then nav to an try to click

Alright! Making some progress :) . So using "type keys" works in playing the video at youtube page. However, this requires the mouse arrow pointer to be used and having the ubot window open and cannot be minimized to be ran in the background. So not ideal for botting.

 

Also, I tried sending the space key, doesn't work to play video.

 

Also tried switching browser from chrome79 to chrome21 and youtube doesn't allow chrome21 browser (outdated).

 

I feel we are close to a solution coming.


I love ubot when it works right  :D 


#10 LoWrIdErTJ - BotGuru

LoWrIdErTJ - BotGuru

    Botguru.net

  • Moderators
  • 4843 posts
  • LocationMichigan
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 07 April 2020 - 10:41 AM

No in fact you don't need to use "type keys"

you can use the type text command so the software doesn't need focus and for content to type put in {SPACE}

 

it will simulate a send key of space to the element you select (the video or page)

 

I personally dont use the latest Ubot software because I dont feel the browser is fully stable enough for my end users.  I use 5.9.55 for this reason and only test on latest version to see how its doing on progress.

 

I also use Exbrowser Chrome mainly instead of the built in so that I have full support for html5, flash, action script, javascript, etc..... 



#11 memeuu

memeuu

    Advanced Member

  • Fellow UBotter
  • PipPipPip
  • 88 posts
  • OS:Windows 10
  • Total Memory:8Gb
  • Framework:v4.5+, unsure
  • License:Developer Edition

Posted 07 April 2020 - 11:53 AM

No in fact you don't need to use "type keys"

you can use the type text command so the software doesn't need focus and for content to type put in {SPACE}

 

it will simulate a send key of space to the element you select (the video or page)

 

I personally dont use the latest Ubot software because I dont feel the browser is fully stable enough for my end users.  I use 5.9.55 for this reason and only test on latest version to see how its doing on progress.

 

I also use Exbrowser Chrome mainly instead of the built in so that I have full support for html5, flash, action script, javascript, etc..... 

Not working with (SPACE), thanks anyways. Not interested in using exbrowser. But at least the type keys is working, I'll just leave the computer running ubot when I'm not using it for now. Thanks for all of your help guys!


I love ubot when it works right  :D 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users